MQTT Discovery setup not working in HA

#1

Hi

I have a Xiaomi temperature sensor (the round one). I see messages incoming on the zigbee2mqtt log:

May 12 09:58:53 pi3 npm[12589]: zigbee2mqtt:info 5/12/2019, 9:58:53 AM MQTT publish: topic ‘zigbee2mqtt/0x00158d0002fa9635’, payload ‘{“temperature”:21.14,“linkquality”:141,“humidity”:47.45}’
May 12 09:58:53 pi3 npm[12589]: zigbee2mqtt:info 5/12/2019, 9:58:53 AM MQTT publish: topic ‘zigbee2mqtt/0x00158d0002fa9635’, payload ‘{“temperature”:21.14,“linkquality”:141,“humidity”:48.32}’

Not sure why each time the message is printed twice, but ok no problem.

My zigbee2mqtt config yaml file says true for HA integration. I’ve rebooted zigbee2mqtt after setting this to true.

My rPi3 is running HA in a docker and Mosquitto (outside docker) to which zigbee2mqtt is connected correctly.

I have the following mqtt configuration on Home Assistant:

15

I don’t get the temperature sensor discovered in HA. Any ideas?

Do I need to change the discovery prefix to ‘zigbee2mqtt’? I’m totally new to mqtt and not quite familiar with the entire setup.

When sending an MQTT message through the HA webUI, I see it appearing when running:
mosquitto_sub -h 127.0.0.1 -v -t “home-assistant/#”

It seems HA is able to talk to Mosquitto and when running the same but with zigbee2mqtt as topic, I also see some logs appearing. Question is now, how do I tie HA and zigbee2mqtt together?

Thanks

#2

Doesn’t HA uses its own broker? If you use 127.0.0.1 in you HA config then HA might only check its local broker. What happens if you enter the IP-address of you mosquitto broker?