No soft transition with Philips Hue bulbs

After pairing a Philips Hue bulb I have noticed that there is no transition time when changing brightness or color with a Hue bulb from the frontend of HA. It changes instantly and doesn´t look nice.
With the Philips Hue bridge there is a soft transition between brightness and color changes.
Is there a general setting for transition time, maybe in the database or something?

In the log I can see the following for the bulb when changing color

Zigbee publish to device ‘0x0017880100be4261’, lightingColorCtrl - moveToColorTemp - {“colortemp”:454,"transtime":0} - {“manufSpec”:0,“disDefaultRsp”:0} - null

I guess that “transtime”:0" has something to do with this.

I’m not familiar with HA but I’d try publishing a message that changes brightness adding the transtime property.
Reading this doc: https://github.com/dresden-elektronik/deconz-rest-plugin/wiki/Philips-Hue-sniffing
It looks like Hue bridge defaults to 0x0004 which is 4 in decimal.

I’m away from home ATM, otherwise I’d try myself.

Gab

I´m not that familiar about publishing these messages but when changing brightness or color from the HA frontend it is not a message I sent mnaually and therefore it would not be possible to add the transtime property to the command anyhow.

I just tried and it doesn’t work :frowning:

:slightly_frowning_face:

I think you can use https://github.com/Koenkk/zigbee2mqtt/issues/1567

My devices.yaml now looks like this but no change. Still no soft transition

'0x0017880100be4261':
  friendly_name: lamp
  retain: false
  homeassistant:
    # transition in seconds
    light:
      transition: 2

and the logs still show “transtime”:0 (I guess it is related to this issue)
Zigbee publish to device ‘0x0017880100be4261’, genLevelCtrl - moveToLevelWithOnOff - {“level”:126**,“transtime”:0**} - {“manufSpec”:0,“disDefaultRsp”:0} - null

I tried again after having a look to the code and it’s working indeed.
If I publish this message:

{"brightness": "255", "transition": 4}

to the topic zigbee2mqtt/<bulbname>/set

I can see a nice and smooth transition. So the converter is working properly. It’s only a matter of understanding why that doesn’t work in homeassistant.

Gab

hmm strange. It is also funny that if I turn on/off from the frontend it HAS a soft transition but when changing color or brightness it reacts instantly.

Yes, I believe ON/OFF transition is somehow built in into the bulb and can’t be changed or avoided. I noticed the same when I was turning on/off the bulb they have a smooth transition without having to specify any transition attribute

But when using HA with the Hue bridge there is a soft transition when changing color and brightness.

As I said before, it looks like Hue bridge defaults to a "transition": 4 when transition is not specified

sorry, my bad. My memory is still on holiday :wink:

But I hope this is solvable as nearly all my lights in the house are Hue and soft transition is pretty important I think.

Do you have an idea what to do about this? Making your suggested change in my devices.yaml didn´t change anything. Is it possible maybe to change some setting for hue in the database?

I’ve just implemented this in the dev branch (see https://github.com/Koenkk/zigbee-shepherd-converters/issues/551#issuecomment-518331726).

I tried to switch to dev branch but get the following error. What can I do. I guess I somehow have to “export” my configuration.yaml to the dev branch or…?

pi@zigbee2mqtt:/opt/zigbee2mqtt $ git checkout dev

error: Your local changes to the following files would be overwritten by checkout:
data/configuration.yaml
Please commit your changes or stash them before you switch branches.
Aborting

You can just follow: https://www.zigbee2mqtt.io/getting_started/running_zigbee2mqtt.html#6-for-later-update-zigbee2mqtt-to-the-latest-version

The only difference between this tutorial and the one I followed is:

git fetch
git checkout dev # Change 'dev' to 'master' to switch back to the release version

And this is the part that returns the error. Can I leave it out?