Cannot pair any device? how to check my setup?

Hi there!

I’m new to zigbee2mqtt.

I followed the installation process and so far, all seems to work fine.

  • CC2531 USB dongle flashed without issue.
  • “npm start” shows this:

$ npm start

> zigbee2mqtt@1.7.1 start /opt/zigbee2mqtt
> node index.js

zigbee2mqtt:info  2019-11-29T17:33:17: Logging to directory: '/opt/zigbee2mqtt/data/log/2019-11-29.18-33-17'
zigbee2mqtt:info  2019-11-29T17:33:18: Starting zigbee2mqtt version 1.7.1 (commit #b459c35)
zigbee2mqtt:info  2019-11-29T17:33:18: Starting zigbee-herdsman...
zigbee2mqtt:info  2019-11-29T17:33:19: zigbee-herdsman started
zigbee2mqtt:info  2019-11-29T17:33:19: Coordinator firmware version: '{"type":"zStack12","meta":{"transportrev":2,"product":0,"majorrel":2,"minorrel":6,"maintrel":3,"revision":20190608}}'
zigbee2mqtt:info  2019-11-29T17:33:19: Currently 0 devices are joined:
zigbee2mqtt:warn  2019-11-29T17:33:19: `permit_join` set to  `true` in configuration.yaml.
zigbee2mqtt:warn  2019-11-29T17:33:19: Allowing new devices to join.
zigbee2mqtt:warn  2019-11-29T17:33:19: Set `permit_join` to `false` once you joined all devices.
zigbee2mqtt:info  2019-11-29T17:33:19: Zigbee: allowing new devices to join.
zigbee2mqtt:info  2019-11-29T17:33:19: Connecting to MQTT server at mqtt://
zigbee2mqtt:info  2019-11-29T17:33:20: Connected to MQTT server
zigbee2mqtt:info  2019-11-29T17:33:20: MQTT publish: topic 'zigbee2mqtt/bridge/state', payload 'online'
zigbee2mqtt:info  2019-11-29T17:33:20: MQTT publish: topic 'zigbee2mqtt/bridge/config', payload '{"version":"1.7.1","commit":"b459c35","coordinator":{"type":"zStack12","meta":{"transportrev":2,"product":0,"majorrel":2,"minorrel":6,"maintrel":3,"revision":20190608}},"log_level":"info","permit_join":true}'

I didn’t go further in the howto (I did not setup the daemon).

But then I tried to pair 2 items.

  • one Xiaomi MCCGQ01LM
  • one Xiaomi WXKG01LM

I followed the recommendations from for each of the devices.
I also tried the keep pressing the reset button trick (every few seconds) to keep it awake.

I tried barely away from receiver (~3m, but in direct view of the antenna, only air in between)
I also very close, like 5cm from USB dongle.

The CC2531 has its bright green led ON & stable.

What could I try to diagnose my issue ?

I ordered a second CC2531 that is on it’s way (make take one more week to arrive).

Found solution (but not the reason).
It was same as here:

Moving the CC2531 to a different USB port and suddently pairing worked… :crazy_face: