Can't pair SP120

Hi Zigbee friends,

I bought a few SP120’s but can’t get them to pair. When I press the button for 5s it starts blinking slowly and kills the power to the connected device. After a few seconds it stops blinking and the LED just turns on. No messages can be seen in zigbee2mqtt log, even not on ‘debug’.

I have two of the same type already connected which work fine. Also have connected several brands of LED lighting (like IKEA Tradfri) which also work great.
The coordinator is use is the CC2531, with f/w There is a total of 12 devices registered at the moment in Zigbee2mqtt. I tried this using Z2M 1.6.0 and Z2M-dev from yesterday.

I tried pairing close to the coordinator, and far away from it (to try if I can force it to pair using one of the LED bulb Zigbee routers). In both situations it shows the same behaviour when trying to pair.

Some weird things I noticed: a cheap LED bulb I bought from ALDI (lol) keeps spamming reports of brightness sometimes, even when the system should be idle. Is this on request by zigbee2mqtt? Could it be possibly there is so much Zigbee traffic that the pairing request is ignored of missed?

Btw, I ordered a second CC2531 for debugging, but it will take a few weeks to arrive :frowning:

Solved, I’m not sure what was the actual fix was though, but I:

  • Reinstalled Arch Linux ARM to aarch64 (did copy the Docker volume over)
  • Disconnected the CC2531 and reconnected it to another port (I might be just the powercycle that fixed it?)