CC Debugger stopped working


I wanted to flash some CC2531 but after the second device I wasn’t able to see the device in the device list of the Flasher Software anymore.

I was running my laptop on battery and it turned itself off because it ran out of battery while Flasher was open (but wasn’t flashing something).

  • I reinstalled the software and drivers.

  • I installed it at another windows machine

But I still don’t get nothing in the list of Flasher.

The debugger however shows a green light.

I’m starting to think that something went wrong and my debugger is trash now.

Anyone with suggestions? @Koenkk ?


I haven’t seen this before. I guess it’s broken.

That’s also my guess now.

Tried to set it to bootloader mode and it does blink red but still doesn’t show up in the list.

They describe another way to fix a bricked debugger but you need a second debugger for that.

Edit: Device is broken. A new one shown up immediately in the list.

Wrong Thread.
But has the same problem.
I tried a second debugger which worked immediatly.