CC1352P-2 'Adaptor Disconnected' problem

I’ve been having a problem with my CC1352P-2 adaptor, it was working fine non stop (months) with no issues until one day I unplugged it from the USB port while it was running, and it hasn’t been the same since.

At first when I plugged it back in, zigbee2mqtt could not connect to the adaptor at all (time out), pressing reset button on the board made no difference. Ended following the procedure to erase and flash it again with the same firmware as was on it before (CC1352P_2_20191106) using uniflash. It worked from that point for about a day, then came up with ‘Adaptor Disconnected’, starting up the docker container again made it work, worked for about half a day before disconnecting and from then randomly disconnecting, be from few minutes to a few hours. Having to restart the docker container each time it disconnects.

I have tried re-flashing CC1352P_2_20200417 but same result, lasts a day without issues and then randomly disconnects from that point. Have also tried re-flashing and removing the coordinator_backup.json file, and starting the pairing process for all the connected devices. Same deal, lasts a day and then disconnects randomly again. Using Uniflash 6.0 it also prompted to update the firmware on the device, but that also made no difference.

Not sure where to go from here. Have I damaged the CC1352P-2 adaptor?

I have 31 Aqara (human, contact, vibration) devices attached to the zigbee network. I haven’t added/removed any devices on the network for a while.

zigbee2mqtt:info  2020-06-02 04:37:20: MQTT publish: topic 'zigbee2mqtt/Master Bedroom Motion',     payload '{"battery":100,"voltage":3015,"illuminance":0,"illuminance_lux":0,"linkquality":75,"occupancy":false,"device":{"friendlyName":"Master Bedroom Motion","model":"RTCGQ11LM","ieeeAddr":"0x00158d0002f3c38b","networkAddress":30366,"type":"EndDevice","manufacturerID":4151,"manufacturerName":"LUMI","powerSource":"Battery","applicationVersion":5},"last_seen":"2020-06-01T19:07:20.486Z"}'
zigbee2mqtt:error 2020-06-02 04:38:57: Adapter disconnected, stopping
zigbee2mqtt:debug 2020-06-02 04:38:57: Saving state to file /app/data/state.json
zigbee2mqtt:info  2020-06-02 04:38:57: MQTT publish: topic 'zigbee2mqtt/bridge/state', payload 'offline'
zigbee2mqtt:info  2020-06-02 04:38:57: Disconnecting from MQTT server
zigbee2mqtt:error 2020-06-02 04:38:57: Failed to stop zigbee
npm ERR! errno 1
npm ERR! zigbee2mqtt@1.13.1 start: `node index.js`
npm ERR! Exit status 1
npm ERR! Failed at the zigbee2mqtt@1.13.1 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2020-06-01T19_08_57_176Z-debug.log

I’ve moved the coordinator to another machine, was on my Synology DS1019+, now on a mid 2010 Mac mini running Ubuntu 18.04.4 LTS.

When the Adaptor Disconnected error occurs it will restart and retry connecting rather than just stopping. Errors it produced while reconnecting:

zigbee2mqtt:error 2020-06-05 01:53:17: Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)
  at ZStackAdapter.<anonymous> (/app/node_modules/zigbee-herdsman/dist/adapter/z-stack/adapter/zStackAdapter.js:71:23)
  at Generator.throw (<anonymous>)
  at rejected (/app/node_modules/zigbee-herdsman/dist/adapter/z-stack/adapter/zStackAdapter.js:6:65)

But eventually, usually a few minutes it will succeed and run again. Any ideas what might be going on here? The is adaptor crashing and constantly rebooting until it succeeds?