CC2530+CC2591 router stuck "offline"

Hoping someone might be able to help shed some light on this. I have cc2531 set up as coordinator, connected to Ri Pi USB and connected to HA via zigbee2mqtt add-on.

Owing to terrible range I then build a cc2530+cc2591 router using the instructions from For several months this has worked flawlessly, reaching xiaomi motion sensors all over my house. Then just recently I noticed some dropouts and then that the router in my network map was noted as being “offline”.

Since then, I have not been able to get the router to stay online having tried various firmware options for both it and the cc2531 coordinator. I have just reflashed again and repaired a couple of devices, network map all looks good with the router showing its status as online.
However the end-devices connected to the router are not actually sending any signal back to the coordinator. A quick restart of zigbee2mqtt addon and it is back to being offline again:

Anyone have any thoughts or routes I could explore to diagnose the issue? Could it be that the cc2530 + cc2951 has simply developed a fault despite giving the appearance of working?