Devices disconnect and need repairing all the time

Ok,

Discord is a pain to use as a day later nobody will read your questions etc so trying this. I would REALLY like some help to finally get zigbee2mqtt working properly, as i have never had it work the way i feel it should, and i’ve been trying seriously for a year, and tinkered a little before then as well.

I have a bit over 30 devices in my network, and i can have them all workign together, but then if i reboot hassio or restart zigbee2mqtt, a bunch of devices will just no longer work. Why? not sure… thats what i need help with.

I run my hassio install on a NUC these days instead of the Pi3 i started on. I thought it was shit netword with lots of sensors an no routers, so i went and got more routers and now run a coordinator and 4 dedicated routers in my small 3 bedroom house using source routing rev 20190619 with all the routers paired to the coordinator one by one before rebuilding my entire network.

I spent the entire weekend rebuilding my network last week and all of it worked. Lots of temperature sensors, door sensors, motion sensors, smoke detector, vibration sensors, push buttons, power switches etc. They all worked and i was a very happy man.
Then after a reboot, everything turned to shit and most my temp sensors dont work anymore, some motion sensors no longer work etc.

It’s extremely frustrating getting to the point where it all works, and then after restarting zigbee2mqtt it all just shits the bed. I can get the sensors back by repairing them, so the sensors and routers etc etc all work, but something just goes terribly wrong somewhere.

How do i figure out whats going wrong? What information do i need to provide for someone who knows more about the inns and outs to figure out whats going on?

One note: i have a ZNCZ02LM Xiaomi Mi power plug that is a router, but i turn it off before pairing new devices and plug it back in when im done… though sometimes it might stay unplugged for a few days. I have a feeling it is a terrible device as it often wont reply to pings, and wont show current draw etc which is a whole different problem. Not sure if turning that on/off will stop devices from using it as their route etc? im not sure if zigbee self heals or if it creates a path and sticks with it etc?

1 Like

I have a similar problem in my network, I’m also using the source-routing firmware currently.
My network consists of ~40 device, half are ikea lightbulbs having routing functionality, the other half are xiaomi aqara sensors (motion/light, temp/hum/baro and switches).
When I setup the whole network, everything works fine, but after a few days or so devices start failing. One day e.g. light A is not reachable on the network and won’t turn on/off. Then the next day light A is back online on the network, but then light B is unresponsive. Then again the day after light B is back in the network and then yet another light fails. I don’t see any logic in this and I don’t see any specific pattern. Most of the time luckily the failing devices get back online after 1 or 2 days without intervention, but sometimes I need to re-enable pairing mode on the zigbee2mqtt controller so the devices automatically re-pair. Sometimes I even need to manually delete the failing devices from the network and then pair them again to get them back into the network.
I really don’t have a clue what is happening, but it’s very annoying since this makes my whole network unreliable. Any thoughts on this would be very welcome.
Regards,
Herman

2 Likes

I’m ‘glad’ i’m not the only one… though i really hope theres a way to solve this issue.
Anyone have any insight?

Could you provide a list of all devices in the network?

@Koenkk
Anything you need.
Is a copy of the database.db file enough? Here is a zip of my entire zigbee2mqtt folder… gives you database files, logs, everything.

Anything you need, just let me know! im an electronics engineer, so happy to tinker around and help in whatever way i can. I can run other code, or run sniffers or whatever you need to try get to the bottom of this…

Heck, if you need it, i can give you remote access into my hassio NUC if that helps you in any way/shape/form.

i run one of these as the coordinator as well as one as a router

i then have 3 more of these as routers
image

I also have one of these, but havent got it plugged in as it somehow completely crippled my system in weird ways…
image

Other than that, i have the following:
1 x WXKG01LM single battery button
2 x WXKG02LM double battery button
2 x QBKG03LM double key aqara powered (unplugged, unpaired)
11 x WSDCGQ01LM Mijia Temp
1 x WSDCGQ11LM Aqara Temp
2 x RTCGQ01LM motion sensor
1 x MCCGQ01LM Mijia door
7 x MCCGQ11LM Aqara door
1 x SJCGQ11LM water leak
1 x ZNCZ02LM Mi power plug zigbee
1 x JTYJ-GD-01LM/BW smoke detector
2 x DJT11LM vibration (one turned off)

I have a bunch more devices that i have sitting on the shelf never used, but thats the ones im using now

Hope that helps!

Ned

I think i have the same Problem.
Yesterday i updated to 1.5.1 and than i never got values from my aqara sensors
i could switch my Osram plugs but my aqara sensors dont work…

i deleted all devices in database.db and configuration.yaml -> repaired two devices and seems to work… but after stop debug Modus and Restart as Service (or manuel)… no values arrived from sensors

@Koenkk

any idea, what could be the Problem?

today i got my cc Debugger and flashed the cc2530 with the Firmware CC2530_DEFAULT_20190608
after i paired all devices it seems to be working now

here you can see some sensors came back. I’ve done nothing… just happens sometimes

Hi Koen,
would be happy to send you my info, but I don’t seem to be able to attach any files to the reply :frowning:
How do I get the data to you ?
Regards,
Herman

and this is what it looks like today… even worse…?
again, i have made no changes, no reboots, no nothing…

and my network map has completely shit the bed
image

and nothing from @Koenkk ?

you got any ideas man? im about ready to try conbee and deconz and see if that works any better… because this is just not even usable anymore… Can’t automate things if the incoming data is flaky at best

What firmware are you using? Can you try putting a device which disconnects often close to the coordinator and see if it stays connected?

Hi @Koenkk

I am using 20190619 - Source Routing

image

So a little hard to add any new devices directly to the coordinator. I can remove a router if you need me to do that though? but in regards to house coverage, i used to have one router, and all the devices in the same place as they are now and they all worked. I have since added 2 more routers around my (small) house with external antennas, so i dont think its a range thing

One of the temp sensors that doesnt work, thats alson in the same room and really close to a coordinator AND router;
Distance of coordinator to ‘Office Router’ :: 1.2m line of sight
Distance from coordinator to ‘Next Bedroom Temp’ :: 2.5m line of sight
Distance from ‘Office Router’ to ‘Next Bedroom Temp’ :: 2m line of sight

for interest sake, here is a pic i took of the ‘office’ and you can see where the coordinator, router and NUC are. The temp sensor is directly behind me. This isnt really an office, it’s a walk in wardrobe, so itrs pretty small :slight_smile:

Here is what the temps look like today just to show whats up. I did actually reboot my entire NUC 12 hours ago and seems nothing came back and nothing new went offline… but one of them came back online (upstairs bathroom temp) at some other point since the last post

I’m having a similar issue with a couple of Aqara switches.
I can pair them and see their events coming into the zigbee2mqtt logs but after a couple of hours they stop working unless I pair them again.
The switch led is blinking which makes me think it reports a problem (I’m just not sure what problem).

I have other switches that don’t have this issue. Is this similar to the issue reported here? Anyone has any idea how this can be solved?

Hello guys.
I have the same problem with motion sensors from Xiaomi Aqara (lumi.sensor_motion.aq2).
Need pairing from time to time, they are connected but not responding. For that I need to cleanup the entries in the configuration.yaml and in the database.db. The database.db also has several entries from the same device with the same ID, normal?
As example I have now 2 connected but not working.
My network is pretty big with lot’s of routers because I use several Xiaomi Mi power plug ZigBee (ZNCZ02LM) (image attached).

I can help debugging the issue. Whatever is needed just ask.
Thanks.

1 Like

Same problem here. I opened a topic as well Devices unreachable and routers offline

1 Like

Same problem here… It reports Device unreachable. Osram LED and movement sensor from ikea works great, but LEDS from ikea always drop out.

I ordered a Conbee II and installed that last night with deConz.
Super easy, hassle free, can use the repeaters i already had for zigbee2mqtt as ‘lights’ to mesh with, and all my sensors paired beautifully! and all still work (only been 12 hours though)

So i’ll update you all in a couple days, but so far i’m super happy with 40-ish devices all going!

Oh man!
Look! All my shit works!
Loving the Conbee II

:heart::heart::heart::heart::heart::heart: