How can a CC2530 be set up ...

Hello everybody,

I contact you because I have some problems with my ZigBee devices.
First of all, I apologize for bad English, I can’t do it properly, so I mostly use Google Translater for longer things, but sometimes garbage comes out - sorry!

I am experimenting with zigbee2mqtt and would like to integrate my Heiman smoke detectors and the Heiman CO detector in Men Domoticz.
To experiment, I bought a small RPI4 with 1GB.

First I worked with a CC2531 and it worked, ie a fire detector was recognized and integrated accordingly, the CO detector is not recognized.

I have edited the configuration files for the revenge detector according to the instructions ( accordingly:
zigbeeModel: [‘SmokeSensor-N-3.0’],
model: ‘HS1SA’,
vendor: ‘HEIMAN’,
description: ‘Smoke detector’,
supports: ‘smoke’,
fromZigbee: [fz.heiman_smoke, fz.battery_200],
toZigbee: [],
meta: {configureKey: 1},
configure: async (device, coordinatorEndpoint) => {
const endpoint = device.getEndpoint (1);
await bind (endpoint, coordinatorEndpoint, [‘genPowerCfg’]);
await configureReporting.batteryPercentageRemaining (endpoint);

And he was recognized immediately - happy!

The CO sensor HS1CA-E (FCC-ID 2AK7XHS1CA) is inside and is not recognized.
The other revenge detectors (same type as the first one) are also found, but are not found on other floors.

Since the range should be limited, I have ordered a GBAN2530 that is already flashed with the correct firmware (CC2530ZNP-Prod.hex ( 19.06.2019) von Koenkk) to solve the range problem.

But new problems have come for me, the piece is not recognized, only the USB - TTL interfaces.

pi @ raspberrypi: ~ / domoticz $ ls -l / dev / serial / by-id
totally 0
lrwxrwxrwx 1 root root Jan 13th 6pm 1pm usb-Silicon_Labs_CP2102_USB_to_UART_Bridge_Controller_0001-if00-port0 -> ../../ttyUSB0

I then adapted the interface in the configuration page but did not.

If there is an easy-to-understand manual for a newby, I think I am doing what is wrong in my naivety so it is not possible.

There is a really good HowTo for setting up a cc2531, but unfortunately not for the 2530.

On a Pi, there is no need to use a USB-TTL adapter. Just connect the CC2530 to your pi.