How to add new device on HassIO?!

I just bought an “iluminize 511.202” Zigbee dimmer and believed the zigbee2mqtt page that it was super simple to add unsupported devices … xD

However, I just can’t get it to work… I TRIED to follow this guide

And this one

But I can’t even figure out how to

docker ps

to find the Container ID

I have a Raspberry Pi 3 B+ with the “normal” Hassio image on it. I did figure out how to ssh into the base device (not through the addon), but that’s it for me…

So what I tried until now is, I added the devices.js file to share/zigbee2mqtt and enabled "zigbee_shepherd_devices": true
Then I added

        zigbeeModel: ['Schalt-Aktor 511.202'],
        model: '511.202',
        vendor: 'Iluminize',
        description: 'Zigbee 3.0 Schalt-Aktor 200W ',
        extend: generic.light_onoff_brightness,

and restarted the addon.

Then I enabled devices join and put the dimmer into pairing mode - even though it seems it was (correctly?!) added to the database.db and devices.yaml files …

{"id":30,"type":"Router","ieeeAddr":"0x14b457abcde2c7c7","nwkAddr":62101,"manufId":4107,"manufName":"iluminize","powerSource":"Mains (single phase)","modelId":"511.202","epList":[1,242],"zclVersion":3,"appVersion":0,"stackVersion":0,"hwVersion":0,"swBuildId":"2.5.3_r40","status":"offline","joinTime":null,"endpoints":{"1":{"profId":260,"epId":1,"devId":256,"inClusterList":[0,3,4,5,6,2821,4096],"outClusterList":[25],"clusters":{"genBasic":{"dir":{"value":1},"attrs":{"9":255,"10":{},"11":"NULL","16389":0,"30721":49246,"30722":528,"30723":255,"30724":1,"34819":0,"34820":0,"36864":2,"36865":1000,"36866":{"0":114,"1":57,"2":239,"3":58,"4":150,"5":6,"6":197,"7":68,"8":160,"9":2,"10":70,"11":33,"12":181,"13":121,"14":147,"15":160},"36867":4107,"65533":1,"zclVersion":3,"appVersion":0,"stackVersion":0,"hwVersion":0,"manufacturerName":"iluminize","modelId":"511.202","dateCode":"NULL","powerSource":1,"appProfileVersion":255,"swBuildId":"2.5.3_r40"}},"genIdentify":{"dir":{"value":1},"attrs":{"65533":1,"identifyTime":0}},"genGroups":{"dir":{"value":1},"attrs":{"65533":1,"nameSupport":0}},"genScenes":{"dir":{"value":1},"attrs":{"65533":1,"count":0,"currentScene":0,"currentGroup":0,"sceneValid":0,"nameSupport":0}},"genOnOff":{"dir":{"value":1},"attrs":{"16387":255,"65533":1,"onOff":1,"globalSceneCtrl":1,"onTime":0,"offWaitTime":0}},"genOta":{"dir":{"value":2},"attrs":{}},"haDiagnostic":{"dir":{"value":1},"attrs":{"65533":1,"numberOfResets":0,"averageMacRetryPerApsMessageSent":0,"lastMessageLqi":0,"lastMessageRssi":0}},"lightLink":{"dir":{"value":1},"attrs":{"65533":1}}}},"242":{"profId":41440,"epId":242,"devId":102,"inClusterList":[33],"outClusterList":[33],"clusters":{"genGreenPowerProxy":{"dir":{"value":3},"attrs":{}}}}},"dateCode":"NULL","_id":"iuJkyfIutmXXHXNs"}


  friendly_name: '0x14b457abcde2c7c7'
  retain: true

… the logs, still say:

  zigbee2mqtt:warn 8/1/2019, 6:15:39 PM Device with modelID '511.202' is not supported.
  zigbee2mqtt:warn 8/1/2019, 6:15:39 PM Please see:

BTW: The dimmer seems to be exactly the same hardware as the ROBB ROB_200-004-0, Sunricher ZG9101SAC-HP and iCasa ICZB-IW11D

Anyone can help?! Or point me into the right direction?! a “for Dummies” guide would be highly appreciated

Hello, i have had the same problem here. you must set “zigbeeModel: [‘511.202’]” and set model to the name you decided.

Thanks - that kind of works … however, brightness does not work :frowning:

And also, zigbee2mqtt crashes a couple of minutes after I started it now - don’t know if that’s related or not

EDIT: also, it was not auto detected, but I had to add it manually to Home Assistant … is that normal?

EDIT2: I just found out, that this device does not support dimming … lol - great advertising on their part… fooled me :woman_shrugging:

There is an similar device with the same size that supports dimming. It’s the 511.201 dimm-aktor.
I’m not using Home Assistant so i can’t tell if this is normal or not