Problems rejoining a hue dimmer switch

Hi all,
I have been running zigbee2mqtt and Home Assistant for about a year now. Today I ran into an issue with a hue dimmer switch. I’ve had the switch paired for a long time. Today I removed it and tried to re-join it. But I can’t get the switch to rejoin.
To remove it, I did a force remove in the zigbee2mqtt webinterface, but I did not tick off block from rejoin.
I reset the switch by holding the setup button for 10 seconds. Everything looks good and the switch starts to flash orange as it should. When I permit join in z2m, the switch flashes green after a short while just like it’s joining the network. The problem is that there is no trace of it in z2m. No notification, no trace in the logs, even on debug level. Since I have no errors or anything, I’m a bit stuck. Joining another identical switch worked flawlessly.
I have found the device ID and searched all config and DB files in HA anf Z2M for it. But there is no trace. I’m also aware of this post Unable to pair Hue remote but I can’t find any trace of the device id in the state.json or database.db files.

I also tried to remove the switch again with:
mosquitto_pub -h core-mosquitto -u -P -t zigbee2mqtt/bridge/config/force_remove -m 0x0017880104e70471

Whereas Z2M replies with:
2023-09-08 20:34:25Cannot force remove, device '0x0017880104e70471' does not exist

Does anyone know what can prevent my switch from rejoining the network?

I’m running hassos on an RPI4 with a Conbee II stick. I have 70ish zigbee devices that woks fine. Just this switch I can’t get to rejoin.