Router Issue: CC2530+CC2591

Hi all!
I’m having some issues with my router, but first of all, my setup:


  • Simil-Raspberry (BananaPi) with ARMBIAN 5.85 - Debian GNU/Linux 9 (stretch)
  • zigbee2mqtt version 1.5.1 (commit #ac3b924)
  • CC2531 USB Stick (with longer USB cable) on firmware version: ‘20190608’
  • Deviced around: less than 10, I think seven.


Distance between Coordinator and Router:

  • not more than 6-8meters, one small wall, into a wardrobe

The setup went well for one month more or less. Some weeks ago I’ve noticed the router was offline. I’ve read somewhere that plugging it on/off three times it should try to re-join the router, but nothing happened. I’ve moved then the router in the same room of the coordinator first, then really near to it, nothing! I’ve tried to delete the registration (stop zigbee2mqtt service, removed from configuration.yaml, database.db, state.json and restarted the service), but nothing happened. So, yesterday, I’ve tried to re-flash the router. I’ve reflashed it at the office (so not near the coordinator). As soon I went back to home, I’ve attached it near to the USB stick. I gets then connected succesfully. After that, I’ve tried to move it back to original location, and nothing appears, router again offline. tried to turn it on/off, nothing. I’ve not tested, honestly, bring the router back near the coordinator, but the distance is really near. I could give a try. BTW the fist thing I’ve tested before reflashing it, was to bring it near, so this test was done…

BTW my questions are:

  1. Suggestions on how debug this behaviour? Is there a way, using the CC Debugger, to see what is going on on the router?
  2. Is there a way to scan/see the network range?
  3. Could the distance be a problem? It’s really near btw (6-8meters) and, as written, the first test was to put it near, without success…

Every suggeston is well appreciated.


Hello, updated zigbee2mqtt to 1.6.0, nothing changed :frowning:

No ideas?

Is the firmware used good or would someone suggest a different one? @Koenkk ideas?
I’ve this hardware in use:

And as power supply a HLK-PM03.

Thanks a lot!