Router not showing in HA

I have a coordinator and 2 routers (both CC2530 + CC2591) Firmware: Zigbee2mqtt 1.14.1

The first router is working fine and I see 3 Entities under the device. The router, Link quality, and LED,


For some reason the second router only showed the Link quality and LED entities in Devices. The top row was missing. I tried deleting it from Devices in HA and restarting the router hoping it would re add it but now it doesn’t show up at all. I do see it in the Zigbee2mqtt log writing this every minute:

zigbee2mqtt:info 2020-07-07 13:48:59: MQTT publish: topic 'zigbee2mqtt/0x00124b001fc6406e', payload '{"led":true,"linkquality":99}'

Im running HASSIO in Docker on Ubuntu 18 with the Mosquito Broker. I have permit_join: true

I can also see it in the Zigbee Map. Coordinator in red, Router 1 is in the middle and the router I can’t see is the one circled.

Also, if there any security issues with posting these hardware addresses?

No there is not.

To see if the problem is on the HA side or Zigbee2mqtt side, use mqtt explorer to see if zigbee2mqtt published a router discovery message.

I managed to get it to show up in HA Devices by force removing and reflashing the firmware. But I’m back to the original issue that only the LED entity comes in not the Router.

In MQTT Explorer I see the same thing. The 6406e is only publishing a LED message where the 107f is publishing both a router message and an LED message.

as already answered, no securty issue, but two comments

  1. If you asked your question, your network is probably not secure. Using a secret network key, not keeping the default one is what will encrypt the zigbee payload.

  2. I recommend using friendly names that might make your debug sessions easier

When it comes to your issue, maybe they need sometime to start reporting their attributes or the pairing did not happen properly, you could try to pair them in closer location to check if they work properly before setting them back on their final position, also if you have lots of noise you might want to chose a clean channel by checking if the freq is far from your wifi channels.

I recently added a new cc2530 router, and notice the same thing. No ‘router’ in HA.

I fixed it. Installed zigbee2mqtt 1.7.1 on a spare SD, and the CC2530 was recognized as a router. Even when I switched back to 1.14.1. Did not even have to re-pair.

I completely rebuilt HA and now it’s working