Setting Homeassistant TRUE blocks Domoticz interaction?

I’m aiming to slowly migrate from Domoticz to, by having both servers run and migrating all devices or groups of devices one by one. I also have tons of scripts running on Domoticz so really prefer doing the migration one step at the time instead of a ‘Big Bang’ change. But it seems to that setting homeassistent: true in configuration.yaml basically blocks communication from Zigbee2MQTT to Domoticz completely. Anyone in the know of why that is? Why couldn’t they coexist? Even if I would just want to run just zigbee2mqttassistant (which is a very nice addition) I need to set homeassistant to true.

And to add just a note: I really LOVE zigbee2mqtt. It is so great not to be dependant on all sorts of bridges and not having to have any privacy concerns, particularly with the Chinese stuff!