Unable to get CC26X2R1 to work

I received my CC26X2R1 yesterday, flashed it with Uniflash, installed z2m 1.7.1, however I can’t get it to work. I tried it with a fresh install on both, a raspi and on ubuntu. The result is the same: zigbee-herdsman is not starting.

My configuration.yaml:

homeassistant: false
permit_join: true
  base_topic: zigbee2mqtt
  server: 'mqtt://localhost'
  log_directory: data/log
  log_level: debug
  port: /dev/ttyACM3

My log:

info  2019-12-14T17:07:35: Starting zigbee2mqtt version 1.7.1 (commit #b459c35)
info  2019-12-14T17:07:35: Starting zigbee-herdsman...
debug 2019-12-14T17:07:35: Using zigbee-herdsman with settings: '{"network":{"panID":6754,"extendedPanID":[221,221,221,221,221,221,221,221],"channelList":[11],"networkKey":"HIDDEN"},"databasePath":"/opt/zigbee2mqtt/data/database.db","databaseBackupPath":"/opt/zigbee2mqtt/data/database.db.backup","backupPath":"/opt/zigbee2mqtt/data/coordinator_backup.json","serialPort":{"baudRate":115200,"rtscts":true,"path":"/dev/ttyACM3"}}'
error 2019-12-14T17:08:41: Error while starting zigbee-herdsman

What am I missing? Is there a manual or setting somewhere that I missed?

The reason z2m does not start is normally a little bit lower than what you pasted.

Thank you for your response, francisp. The logfile ends with that entry and z2m terminates. How can I enable more log output?

How are you running zigbee2mqtt ? On bare metal or some sort of docker ?

I don’t use docker or any other container. I was running z2m on a Raspberry Pi 4 (openhabian distribution), and on my notebook (ubuntu 18.04 LTS). Both with the same result as above.

With a CC2531 dongle it works smoth on both sides.

Well, 1.8.0 is released, maybe try this one first.

Just to mention the obvious (because I’m forgetful myself); did you remember to give permissions to the user running z2m to access your new dongle at /dev/ttyACM3?

I just updated to 1.8.0. It is more talkative:

zigbee2mqtt:error 2019-12-15 20:48:44: Error while starting zigbee-herdsman
zigbee2mqtt:error 2019-12-15 20:48:44: Failed to start zigbee
zigbee2mqtt:error 2019-12-15 20:48:44: Exiting...
zigbee2mqtt:error 2019-12-15 20:48:44: Error: Coordinator failed to start, probably the panID is already in use, try a different panID or channel

Explicitly set a non default pan_id in configuration.yaml and now it is up and running.

Thanks francisp and LoPro!

Got the same problem switching to CC26X2R1 from CC2531, changed pan_id but also channel. Actually it is logical, probably other solution would be switch all devices connected to old network off and then the network will be “free”, but it is only wild guess.