Problem getting ZZH / CC2652 to work

I have a zzh! CC2652R Multiprotocol RF Stick that i intend to use as an upgrade for a generic working CC25xx stick.

The blinky firmware works, flashing the firmware with seems to work but it does mention “Connecting to target…
CC1350 PG2.0 (7x7mm): 352KB Flash, 20KB SRAM, CCFG.BL_CONFIG at 0x00057FD8”. Which is a bit strange as this is expected to be a CC2652.

I’m flashing the CC26X2R1_20201026.hex firmware.

The new stick won’t work. Zigbee herdsman reports :
zigbee-herdsman:adapter:zStack:znp:log Opening SerialPort with /dev/ttyUSB2 and {“baudRate”:115200,“rtscts”:false,“autoOpen”:false} +0ms
zigbee-herdsman:adapter:zStack:znp:log Serialport opened +25ms
zigbee-herdsman:adapter:zStack:znp:log Writing skip bootloader payload +472ms
zigbee-herdsman:adapter:zStack:unpi:writer --> buffer [239] +0ms
zigbee-herdsman:adapter:zStack:znp:SREQ --> SYS - ping - {“capabilities”:1} +0ms
zigbee-herdsman:adapter:zStack:unpi:writer --> frame [254,0,33,1,32] +1s
zigbee-herdsman:adapter:zStack:unpi:parser <-- [0] +0ms
zigbee-herdsman:adapter:zStack:unpi:parser — parseNext [0] +3ms

I have these questions :

  • am i doing anything wrong ?
  • why does report a CC1350 ?
  • is there a way to test the firmware and stick without zigbee herdsman ?

The guides are :

The firmware is from the Z-Stack_3.x.0

Thanks, Ivo

Have you tried flashing the stick again? I had something very similar when I upgraded to a zzh from a 2531. Although it apparently flashed ok the first time, it didn’t work. After poking around I couldn’t see what was wrong so as a last resort I flashed it again. This time everything worked fine and I’ve been using it ever since.

Flash again, using the from

Flashing guide can be found here:

If you are upgrading from CC2531 (or something similar), you need to change the pan_id of zigbee2mqtt won’t start.

I flashed the same image again, this time with TI UniFlash and a Debugger DevPack (an XDS110). It works now.

As described in the documentation, i did have to re-pair the network.