Transfer zigbee2mqtt to new SSD

I have just configured a new ssd drive for zigbee2mqtt and copied my existing “data” folder from my old drive.
All but one light is working. It is a Gledopto RGBW controller. I tried to reset it and pair it again but no luck.
I can pair it to my Hue Bridge without issues and I am also able to pair other products to zigbee2mqtt.
I have also noticed that my state.json file looks strange now. Normally it is a fine vertical list but now it only consists of one line of text.
Anyone has an idea what to do?

I have now succeeded in pairing the Gledopto controller with zigbee2mqtt (I tried a lot of times and finally it succeeded). Anyhow the light connected to the controller can´t be controlled by HA. It just stays on all the time.
Anyone knows what can cause this. Everything seems fine in HA.

Probably you have messed up the line endings when you copied the file from one disk or another - or you used the wrong editor to view it. Make sure that it has Unix line endings. Maybe is of help.

The gledopto controllers don’t like the off command. Same with deconz.
Set it to brightness 0 to turn off

Yes but it worked fine before copying the project to a new SSD. When powering up the gledopto the lights turns on but can´t be changed, neither brightness nor color.
In HA anyway everything looks okay and it looks as if it works but nothing happens.

I can copy the json file to the “data” folder on the SSD and open it with notepad++ and everything looks fine. It first gets messed up when stopping zigbee2mqtt.

Has there been a change for the integration of Gledopto lately that could maybe cause this?
I can see that there is now support for both a GL-C-007-1ID and GL-C-007-2ID version.
I don´t recall that my controller had one of these version names.

I have noticed that when pairing with the Hue bridge 2 different lights show up for the Gledopto Controller. One for “dimmable light” and one for “extended color light” They seem dependent of each other but one of them has no effect when changing brightness and color.
When pairing in z2m I get only one light showing in devices.