Which firmware to choose for CC2531 - Z-Stack-Version

@Koenkk there are currently to different available firmware versions for the CC2531.

Which one should I choose and why?
1.2 HA or 3.0?

What does HA mean in that case. Home Assistant?

Found this.

So 3.0 is experimental.

Yes 3.0 is indeed experimental and doesn’t have a benefit over 1.2 at the moment.

1 Like

I tried new firmware this week but it became quite a drama.

The reason I upgraded from 20190109 was that some devices are lost after a few weeks or months. Previous version was pretty stable except of this.

First I tried latest 1.2(20190425). I follewed the guides but still I had te repair my 32 devices. With latest 1.2 firmware I wasn’t able to pair any of my Ikea GU10 lamps. Timeout 10000ms receiving device descriptor, while I never had these problems before.

Because I had te re-pair everything I decided to try 3.0(20190425), but this was even worse. Z2M wasn’t able to start 90% of my tries. If I could start it (power off/on usb, or reset with the button) Z2M could not find any route to my paired routers, so no data at all.

Finally I went back to MAX_STABILITY_20190315. Most of my devices paired okay, still have to add some today.

My network has the following devices:

Synology DS418j


Routers (+/- 12)
4 Ikea GU10
2 Ikea E14
1 Gledopto Outdoor RGB Floodlight
1 Paulmann Led RGB Controller
1 Ikea Socket
2 Xiaomi Sockets
1 Ikea repeater

End devices (+/- 17)
4 Xiaomi Mijia Door switches
3 Xiaomi Mijia Temperature, Humidity switches
5 Xiaomi Wall switches
2 Xiaomi/Honeywell Smoke detectors
2 Xiaomi Motion detectors
1 Xiaomi Cube

What a nightmare, thanks for sharing your experience with 3.0.

Hopefully you can repair all your devices with any other issues.

I’ve updated the firmware to the 20190425 version, and “almost” everything when well. All previouly paired devices worked ok, and the new ones are pairing ok… but I have a little nag.

If I generate the graphviz of my network, all old devices appears without route, while the newly paired showed with a route. Even if I repair one of the old devices, they still shows as not-routed. Any idea about this?

Apart from that, everything seems to be working ok.

So if I’m correct firmware 1.2 is zigbee 1.0 and with firmware it is zigbee 3.0 (Which is not stable yet)