Zigbee network gets unreliable after few days

Hi!

I wish somebode help me debug longterm problems with my setup. I am using slaesh’s CC2652RB stick now and I have troubles get everything working for more than few days. I’ve network with ~40 devices (mostly Xiaomi sensors, few Tradfri bulbs, one Danalock, one Sonoff Zigbee Basic) with custom node-red home automation. Everything is working just fine for few days and after some time devices get unresponsive or very slow. I have already replaced “everything” (upgraded to Raspberry4, changed stick from CC2531 to CC2652RB, reinstalled raspbian and docker, using the newest 1.15.0 Z2M) I’ve already eliminated interference from my wifi router and now I do not know what can be done more. Everytime I restart Z2M everything is working flawlessly again.

Can someone help me debug my failing network?

Here is a debug log from herdsman:

Zigbee2MQTT:error 2020-10-25 21:42:50: Publish 'set' 'brightness' to 'tradfri-chodba' failed: 'Error: Command 0x000b57fffecae767/1 genLevelCtrl.moveToLevelWithOnOff({"level":102,"transtime":10}, {"timeout":10000,"disableResponse":false,"disableRecovery":false,"disableDefaultResponse":false,"direction":0,"srcEndpoint":null,"reservedBits":0,"manufacturerCode":null,"transactionSequenceNumber":null}) failed (SRSP - AF - dataRequest after 6000ms)'
Zigbee2MQTT:debug 2020-10-25 21:42:50: Error: Command 0x000b57fffecae767/1 genLevelCtrl.moveToLevelWithOnOff({"level":102,"transtime":10}, {"timeout":10000,"disableResponse":false,"disableRecovery":false,"disableDefaultResponse":false,"direction":0,"srcEndpoint":null,"reservedBits":0,"manufacturerCode":null,"transactionSequenceNumber":null}) failed (SRSP - AF - dataRequest after 6000ms)
    at Timeout._onTimeout (/app/node_modules/zigbee-herdsman/dist/utils/waitress.js:46:35)
    at listOnTimeout (internal/timers.js:549:17)
    at processTimers (internal/timers.js:492:7)
Zigbee2MQTT:info  2020-10-25 21:42:50: MQTT publish: topic 'zigbee2mqtt/bridge/log', payload '{"message":"Publish 'set' 'brightness' to 'tradfri-chodba' failed: 'Error: Command 0x000b57fffecae767/1 genLevelCtrl.moveToLevelWithOnOff({\"level\":102,\"transtime\":10}, {\"timeout\":10000,\"disableResponse\":false,\"disableRecovery\":false,\"disableDefaultResponse\":false,\"direction\":0,\"srcEndpoint\":null,\"reservedBits\":0,\"manufacturerCode\":null,\"transactionSequenceNumber\":null}) failed (SRSP - AF - dataRequest after 6000ms)'","meta":{"friendly_name":"tradfri-chodba"},"type":"zigbee_publish_error"}'
Zigbee2MQTT:debug 2020-10-25 21:42:50: Publishing 'set' 'transition' to 'tradfri-chodba'
  zigbee-herdsman:adapter:zStack:adapter sendZclFrameToEndpointInternal 0x000b57fffecae767:32851/1 (0,0,5) +6s
  zigbee-herdsman:adapter:zStack:znp:SREQ --> AF - dataRequest - {"dstaddr":32851,"destendpoint":1,"srcendpoint":1,"clusterid":8,"transid":10,"options":0,"radius":30,"len":6,"data":{"type":"Buffer","data":[1,184,4,102,10,0]}} +6s
  zigbee-herdsman:adapter:zStack:unpi:writer --> frame [254,16,36,1,83,128,1,1,8,0,10,0,30,6,1,184,4,102,10,0,45] +6s
  zigbee-herdsman:controller:endpoint Command 0x000b57fffecae767/1 genLevelCtrl.moveToLevelWithOnOff({"level":0,"transtime":10}, {"timeout":10000,"disableResponse":false,"disableRecovery":false,"disableDefaultResponse":false,"direction":0,"srcEndpoint":null,"reservedBits":0,"manufacturerCode":null,"transactionSequenceNumber":null}) failed (SRSP - AF - dataRequest after 6000ms) +6s
Zigbee2MQTT:error 2020-10-25 21:42:56: Publish 'set' 'brightness' to 'tradfri-chodba' failed: 'Error: Command 0x000b57fffecae767/1 genLevelCtrl.moveToLevelWithOnOff({"level":0,"transtime":10}, {"timeout":10000,"disableResponse":false,"disableRecovery":false,"disableDefaultResponse":false,"direction":0,"srcEndpoint":null,"reservedBits":0,"manufacturerCode":null,"transactionSequenceNumber":null}) failed (SRSP - AF - dataRequest after 6000ms)'
Zigbee2MQTT:debug 2020-10-25 21:42:56: Error: Command 0x000b57fffecae767/1 genLevelCtrl.moveToLevelWithOnOff({"level":0,"transtime":10}, {"timeout":10000,"disableResponse":false,"disableRecovery":false,"disableDefaultResponse":false,"direction":0,"srcEndpoint":null,"reservedBits":0,"manufacturerCode":null,"transactionSequenceNumber":null}) failed (SRSP - AF - dataRequest after 6000ms)
    at Timeout._onTimeout (/app/node_modules/zigbee-herdsman/dist/utils/waitress.js:46:35)
    at listOnTimeout (internal/timers.js:549:17)
    at processTimers (internal/timers.js:492:7)
Zigbee2MQTT:info  2020-10-25 21:42:56: MQTT publish: topic 'zigbee2mqtt/bridge/log', payload '{"message":"Publish 'set' 'brightness' to 'tradfri-chodba' failed: 'Error: Command 0x000b57fffecae767/1 genLevelCtrl.moveToLevelWithOnOff({\"level\":0,\"transtime\":10}, {\"timeout\":10000,\"disableResponse\":false,\"disableRecovery\":false,\"disableDefaultResponse\":false,\"direction\":0,\"srcEndpoint\":null,\"reservedBits\":0,\"manufacturerCode\":null,\"transactionSequenceNumber\":null}) failed (SRSP - AF - dataRequest after 6000ms)'","meta":{"friendly_name":"tradfri-chodba"},"type":"zigbee_publish_error"}'
Zigbee2MQTT:debug 2020-10-25 21:42:56: Publishing 'set' 'transition' to 'tradfri-chodba'
  zigbee-herdsman:adapter:zStack:adapter sendZclFrameToEndpointInternal 0x000b57fffecae767:32851/1 (0,0,4) +6s
  zigbee-herdsman:adapter:zStack:znp:SREQ --> AF - dataRequest - {"dstaddr":32851,"destendpoint":1,"srcendpoint":1,"clusterid":8,"transid":11,"options":0,"radius":30,"len":6,"data":{"type":"Buffer","data":[1,185,4,0,10,0]}} +6s
  zigbee-herdsman:adapter:zStack:unpi:writer --> frame [254,16,36,1,83,128,1,1,8,0,11,0,30,6,1,185,4,0,10,0,75] +6s
  zigbee-herdsman:controller:endpoint Command 0x000b57fffecae767/1 genLevelCtrl.moveToLevelWithOnOff({"level":102,"transtime":10}, {"timeout":10000,"disableResponse":false,"disableRecovery":false,"disableDefaultResponse":false,"direction":0,"srcEndpoint":null,"reservedBits":0,"manufacturerCode":null,"transactionSequenceNumber":null}) failed (SRSP - AF - dataRequest after 6000ms) +6s
Zigbee2MQTT:error 2020-10-25 21:43:02: Publish 'set' 'brightness' to 'tradfri-chodba' failed: 'Error: Command 0x000b57fffecae767/1 genLevelCtrl.moveToLevelWithOnOff({"level":102,"transtime":10}, {"timeout":10000,"disableResponse":false,"disableRecovery":false,"disableDefaultResponse":false,"direction":0,"srcEndpoint":null,"reservedBits":0,"manufacturerCode":null,"transactionSequenceNumber":null}) failed (SRSP - AF - dataRequest after 6000ms)'
Zigbee2MQTT:debug 2020-10-25 21:43:02: Error: Command 0x000b57fffecae767/1 genLevelCtrl.moveToLevelWithOnOff({"level":102,"transtime":10}, {"timeout":10000,"disableResponse":false,"disableRecovery":false,"disableDefaultResponse":false,"direction":0,"srcEndpoint":null,"reservedBits":0,"manufacturerCode":null,"transactionSequenceNumber":null}) failed (SRSP - AF - dataRequest after 6000ms)
    at Timeout._onTimeout (/app/node_modules/zigbee-herdsman/dist/utils/waitress.js:46:35)
    at listOnTimeout (internal/timers.js:549:17)
    at processTimers (internal/timers.js:492:7)

And debug log of Z2M:

debug 2020-10-25 21:43:02: Publishing 'set' 'transition' to 'tradfri-chodba'
error 2020-10-25 21:43:08: Publish 'set' 'brightness' to 'tradfri-chodba' failed: 'Error: Command 0x000b57fffecae767/1 genLevelCtrl.moveToLevelWithOnOff({"level":0,"transtime":10}, {"timeout":10000,"disableResponse":false,"disableRecovery":false,"disableDefaultResponse":false,"direction":0,"srcEndpoint":null,"reservedBits":0,"manufacturerCode":null,"transactionSequenceNumber":null}) failed (SRSP - AF - dataRequest after 6000ms)'
debug 2020-10-25 21:43:08: Error: Command 0x000b57fffecae767/1 genLevelCtrl.moveToLevelWithOnOff({"level":0,"transtime":10}, {"timeout":10000,"disableResponse":false,"disableRecovery":false,"disableDefaultResponse":false,"direction":0,"srcEndpoint":null,"reservedBits":0,"manufacturerCode":null,"transactionSequenceNumber":null}) failed (SRSP - AF - dataRequest after 6000ms)
    at Timeout._onTimeout (/app/node_modules/zigbee-herdsman/dist/utils/waitress.js:46:35)
    at listOnTimeout (internal/timers.js:549:17)
    at processTimers (internal/timers.js:492:7)
info  2020-10-25 21:43:08: MQTT publish: topic 'zigbee2mqtt/bridge/log', payload '{"message":"Publish 'set' 'brightness' to 'tradfri-chodba' failed: 'Error: Command 0x000b57fffecae767/1 genLevelCtrl.moveToLevelWithOnOff({\"level\":0,\"transtime\":10}, {\"timeout\":10000,\"disableResponse\":false,\"disableRecovery\":false,\"disableDefaultResponse\":false,\"direction\":0,\"srcEndpoint\":null,\"reservedBits\":0,\"manufacturerCode\":null,\"transacti
onSequenceNumber\":null}) failed (SRSP - AF - dataRequest after 6000ms)'","meta":{"friendly_name":"tradfri-chodba"},"type":"zigbee_publish_error"}'
debug 2020-10-25 21:43:08: Publishing 'set' 'transition' to 'tradfri-chodba'
error 2020-10-25 21:43:14: Publish 'set' 'brightness' to 'tradfri-chodba' failed: 'Error: Command 0x000b57fffecae767/1 genLevelCtrl.moveToLevelWithOnOff({"level":51,"transtime":10}, {"timeout":10000,"disableResponse":false,"disableRecovery":false,"disableDefaultResponse":false,"direction":0,"srcEndpoint":null,"reservedBits":0,"manufacturerCode":null,"transactionSequenceNumber":null}) failed (SRSP - AF - dataRequest after 6000ms)'
debug 2020-10-25 21:43:14: Error: Command 0x000b57fffecae767/1 genLevelCtrl.moveToLevelWithOnOff({"level":51,"transtime":10}, {"timeout":10000,"disableResponse":false,"disableRecovery":false,"disableDefaultResponse":false,"direction":0,"srcEndpoint":null,"reservedBits":0,"manufacturerCode":null,"transactionSequenceNumber":null}) failed (SRSP - AF - dataRequest after 6000ms)

Nobody knows anything?

It’s a long shot but is all the firmware up to date?

I noticed a improvement especially when I updated the firmware on the Ikea powerplug. I use zigbee2mqtt in home assistant unfortunately the OTA is not working see this post. But if you run zignee2mqtt in a docker there is a chance you can get it working.

Due to the holiday season I am using a lot of Ikea powerplugs from last year and they have all outdated firmware so i’m experience also some problems.

I’m using a CC26X2R1. I recently bought an antenna for this board because it on a far corner of my house and the coordinator only have a weak connection with a few routers. I hope that with this antenna I can connect the coordinator with a stronger signal to more routers so it will improve the quality of my zigbee mesh (no idea of this will work). I’m still waiting on the slow boat from China.

Yep… all latest firmware…

But I have managed to resolve this issue:


4) 1. Avoid adding Zigbee lightbulbs to your hub in combination with other Zigbee devices, since the lightbulbs will try to act as routers, but unfortunately they only perform this role properly with other lightbulbs. The exception we have found are Sengled Zigbee lightbulbs, which do not try to take on the role of repeating other Zigbee devices. Zigbee light bulbs do not have issues routing among themselves, therefore a good alternative is a separate Zigbee network via a compatible bridge such as the Philips Hub Bridge, or a second Hubitat Elevation hub with only Zigbee lightbulbs paired to it. This will avoid this issue of bulbs attempting, and subsequently failing to repeat signals for other devices, by establishing two separate and stable Zigbee networks. NOTE : Devices on a separate Zigbee network cannot repeat signals for devices on the main Zigbee network.

I have removed all my tradfri devices and I am stable for 14 days now… So bye bye Tradfri :frowning: