Cannot pair E1743 (tradfri on/off switch)

Hi,
I’m having trouble pairing the tradfri switch to Zigbee2MQTT. I’m using version 1.7.1. Tried two different tradfri remotes. They have firmware version 2.0.020 and 2.2.008 (latest).

Tried the procedure multiples times (>20):

  1. Allow devices to join
  2. press 4 times link button
  3. Device glows, after a few seconds begins pulsing
  4. Waiting (tried also to push or hold on/off button)

No luck. Tried to hold it near the sniffer… 2cm - 2 meters…

Logging shows no activity in home-assistant

Does someone has any suggestions?

Regards

Try restarting zigbee2mqtt first. Might help.

Hi Francis,
Thanks for the tip. Unfortunatly I tried that several times (including restarting complete server). No luck.
Regards

Did some extra research:
Changed batteries of the on/off switches ==> no success

I did find a device with no components in zigbee2mqtt assistant. I remember when I tried to pair the first switch I saw in the log that a unknown device was found.

Can it be that this blocks the pairing of the on/off switches? I don’t think because I tried to pair 2 switches so than I would suspect that 2 unknown devices were detected. I only see one.

However. I tried to remove the device (zigbee2mqttassistant) but I get an error message. Manually removing from configuration.yaml didn’t work. So the device still shows.

Any suggestions how to proceed and also howto remove the device?

regards

I did solve the issues (by accident)

  1. Not pairing of the E1743
    I had to stop Zigbee2MQTT, remove the C2531 from USB port, insert it again and restart Zigbee2MQTT.
    Voila, immediately pairing both the Tradfri switches.

  2. Removing device with no components
    I had to force remove the device with MQTT. Normal removing (Zigbee2MQTT assistant) doesn’t work.

Regards

1 Like

This sounds similar to an issue that we had with the Ikea outlets when they came out - after pairing one you couldn’t pair anything else until you rebooted and then reset the stick using the button next to the green LED before starting zigbee2mqtt.

Thanks, I had the same issue and and had success with pairing the switch by this method.