Configure attribute reporting for Innr SP120 or any Zigbee device?

Is it possible with zigbee2mqtt set attributes for the device itself? Like the Innr SP120 power socket. Innr customer support told me that I should change the values how often these sockets report value changes to home automation. Like this:

  • Set the MinimumReportingInterval and MaximumReportingInterval to 0x000A (10 seconds) for example
  • Set the MaximumReportingInterval to 0xFFFF to disable reports for the attribute altogether
  • Set the MaximumReportingInterval to 0xoE10 (3600 decimal), and set the ReportableChange to 0x0014 (20 decimal) so that a report is only sent if there is a voltage change higher than 20V, or once every hour.

I have multiple of these sockets and they keep flooding the zigbee-network with voltage fluctuation even if the socket is offline. If this is not possible with zigbee2mqtt how would you do it? Thnx!


Okay am I in the right direction for modifying device settings:
mosquitto_pub -h -t 'zigbee2mqtt/bridge/config/device_options' -m '{"friendly_name": "0x00158d0003447cd1","options":{"MaximumReportingInterval":"0xFFFF"}}'

And I get a reply from zigbee2mqtt:
Changed device specific options of '0x00158d0003447cd1' ({"MaximumReportingInterval":"0xFFFF"})

This should turn off the reporting but it did not do anything? What did I do wrong or left out? :slight_smile: Thnx!