[SOLVED] CC1352P-2: trouble starting Z2M on RPi

EDIT: I’m not sure why, but after some more troubleshooting that didn’t seem to address the problem, I got a different message that the panID is already in use. So changing the panID got Z2M started just fine now.

Hello,
I have a CC1352P-2 running on a raspberry pi 3 using the latest Raspbian Buster Lite.

After installing Z2M, and running “npm start”, I get this error. Looks like a timeout.

zigbee2mqtt:info  2019-12-25 00:29:30: Logging to console and directory: '/opt/zigbee2mqtt/data/log/2019-12-25.00-29-30'
zigbee2mqtt:info  2019-12-25 00:29:31: Starting zigbee2mqtt version 1.8.0 (commit #da4d26a)
zigbee2mqtt:info  2019-12-25 00:29:31: Starting zigbee-herdsman...
zigbee2mqtt:error 2019-12-25 00:29:38: Error while starting zigbee-herdsman
zigbee2mqtt:error 2019-12-25 00:29:38: Failed to start zigbee
zigbee2mqtt:error 2019-12-25 00:29:38: Exiting...
zigbee2mqtt:error 2019-12-25 00:29:38: Error: SRSP - SYS - version after 6000ms
    at Timeout._onTimeout (/opt/zigbee2mqtt/node_modules/zigbee-herdsman/dist/utils/waitress.js:44:24)
    at listOnTimeout (internal/timers.js:531:17)
    at processTimers (internal/timers.js:475:7)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! zigbee2mqtt@1.8.0 start: `node index.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the zigbee2mqtt@1.8.0 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/pi/.npm/_logs/2019-12-25T06_29_39_041Z-debug.log

I’ve gone through the basic troubleshooting. I’ve tried both ttyACM0 and ttyACM1:

pi@raspberrypi:/opt/zigbee2mqtt/data $ test -w /dev/ttyACM0 && echo success || echo failure
success
pi@raspberrypi:/opt/zigbee2mqtt/data $ test -w /dev/ttyACM1 && echo success || echo failure
success

I’ve tried both ACM0 and ACM1 in the configuration.yaml. Both produce this failure. Here’s what the config looks like:

# Home Assistant integration (MQTT discovery)
homeassistant: false

# allow new devices to join
permit_join: true

# MQTT settings
mqtt:
  # MQTT base topic for zigbee2mqtt MQTT messages
  base_topic: zigbee2mqtt
  # MQTT server URL
  server: 'mqtt://localhost'
  # MQTT server authentication, uncomment if required:
  # user: my_user
  # password: my_password

# Serial settings
serial:
  # Location of CC2531 USB sniffer
  port: /dev/ttyACM0

I read the github issue about issues with versions of the CC1352 board. I couldn’t tell my chip revision, but it looks like I have board revision B according to the uniflash device info. This should be compatible with the binary.

I’m wondering what other troubleshooting tips are out there?

Did you try /dev/serial/by-id ?

Yes, here’s the output:

pi@raspberrypi:~ $ ls -l /dev/serial/by-id
total 0
lrwxrwxrwx 1 root root 13 Dec 25 09:34 usb-Texas_Instruments_XDS110__03.00.00.05__Embed_with_CMSIS-DAP_L430019T-if00 -> …/…/ttyACM0
lrwxrwxrwx 1 root root 13 Dec 25 09:34 usb-Texas_Instruments_XDS110__03.00.00.05__Embed_with_CMSIS-DAP_L430019T-if03 -> …/…/ttyACM1