CC2531 USB device disconnects when permit join enabled

Hi,

I am running Zigbee2mqtt v1.15.0 with HassOS 4.13 running on VirtualBox. All has been working great but I’ve been trying to add a new Philips hue bulb. Seconds after I click permit join in the Zigbee2mqtt tab the CC2531 USB device stops responding with the following error in the system log:

usb 2-2: USB disconnect, device number 8
cdc_acm 2-2:1.0: failed to set dtr/rts

This happens every time. To get it working again I have to stop Zigbee2mqtt, disconnect the CC2531 from USB, wait some time, reconnect the CC2531 and start Zigbee2mqtt and all is fine until I attempt another permit join.

I thought it might be too many devices being added (I’m now up to 20 devices) so I removed an Ikea remote forcefully and took the battery out of it, but this didn’t help.

I did have an issue when going to version 1.15.0 of Zigbee2mqtt but I reset the config to default which appeared to resolve my issues. I am not sure if this is an issue with the latest release or something else.

Does anyone have any ideas?

Thank you!

I’ve been trying to resolve this issue and appear to have made things worse now! I have removed some devices in an attempt to see if I could re-add them and now I can’t add them back to my Zigbee network!

I’ve attempted many reboots, different USB ports on my PC, upgrading to the Edge version of Zigbee2mqtt all with no luck. I tried to pair another out of the box sensor and still no luck there. Without the Philips Hue bulb on the CC2531 seems to last longer but still will fail when put into discovery mode for a period of time. I was able to factory reset the Hue bulb with the CC2531 using touchlink but still no luck pairing it.

Is my CC2531 faulty? Should I look to buy an alternative?

That’s the exact behavior that I see in my CC2531 too !
My permit join is enabled since the beginning as I was still going to add a few more devices and I never thought to set it to false. Now, that you mentioned it, I tried to set it to false and indeed, my CC2531 coordinator doesn’t disconnect anymore (I will wait some more as it might disconnect later, but for now it works fine).
Anybody has the same behavior ?

I managed to get over this issue by writing the source routing firmware advertised in many places (this one is one of them).

Now I am able to add new devices to my network and to control the existing devices. Writing the new FW didn’t affect the already paired devices, so it was quite alright.

My CC debugger and cables along with a new Cc2531 should arrive any day now so I’m hoping I can get this working soon. Going back to manual light switching is a pain!

Which firmware did you use? My current Cc2531 which appears to be bricked for now has the firmware recommended I believe. CC2531_DEFAULT_20190608.zip

Is this what you’re using @ionut?

Hi @Nick, I’ve used this firmware:

https://github.com/Koenkk/Z-Stack-firmware/blob/master/coordinator/Z-Stack_Home_1.2/bin/source_routing/CC2531_SOURCE_ROUTING_20190619.zip

And yes, I have been using the default firmware, the same as yours.

Regards

Thanks @ionut, I’ve read a little about this now and will see how I get on once my debugger arrives. I didn’t think my network was that large to need source routing (I have 20 devices, 12 of which are constantly powered plugs or bulbs and 8 sensors or remotes) but if the standard firmware does not work then I’ll try this one out.

I have recently purchased a eufy security camera setup inc. doorbell and was wondering if the 2.4Ghz range from that was causing interference. I couldn’t join devices to my network which were previously joined and even brand-new devices of the same type I couldn’t get recognised.