Unable to pair Hue remote

Hi.
I Upgraded my cc2531 from version 20190425 to 20190608 and I had to pair all my zigbee devices again to get it working, but for some reason my Philips Hue dimmer switch doesn’t join again.
I see in the debug log that it announce itself but then nothing happens:
Device ‘0x001788010xxxxxxx’ announced itself

I have tried to factory reset the dimmer by pressing the reset button +10 sec.
I’ve also tried pressing all four buttons on the dimmer +4sec
and I’ve followed the factory reset procedure descibed here https://www.reddit.com/r/Hue/comments/3qbzvy/cannot_connect_hue_dimmer_kit_switch/

But I always get the same result, nothing happens after zigbee2mqtt logs that the device announce itself.

Some system info:
Philips Hue dimmer switch
model: 9290012573A
vendor: Philips
description: Hue white and color ambiance E26/E27/E14

Zigbee2mqtt version: 1.8.0
cc2531 firmware: 20190608
Bare metal install on: openSUSE Leap 15.1
Kernel: Linux basil 4.12.14-lp151.28.36-default #1 SMP Fri Dec 6 13:50:27 UTC 2019 (8f4a495) x86_64 x86_64 x86_64 GNU/Linux
Python version: 2.7.14
Node Version: v10.16.3
npm version: 6.9.0
I’m not running in Python Virtual Environment

Any suggestions on how to proceed on how to get my dimmer to pair again?
Thanks in advance

Just for the record (in case someone else runs in to a similar challenge)

I finally manage to re-pair my Hue dimmer by stopping zigbee2mqtt, removing all traces from the previously registration by manually deleting the entries for my dimmer from configuration.yaml, state.json and database.db and then stating zigbee2mqtt.
After that I was able to complete the pairing.

Cheers