Install Z2M failed

Good afternoon, everyone,

I have been trying to install Z2M successfully for a long time. First I tried to install it on the Raspbian Full Edition but without success.
In the second step I took the reduced version of Raspbian, unfortunately this did not work. :frowning:

In Node Red I was pointed to the Zigbee Node, after I installed it I could mount my devices. But all devices are deleted from the list. The whole even twice.
In total I had about 12 Xiaomi devices connected.

FLOW
[{“id”:“1fc8df12.879ca1”,“type”:“zigbee-converter”,“z”:“d53ff3b0.4f181”,“shepherd”:“da1e0250.a3327”,“name”:"",“topic”:“zigbee/xiaomi”,“settopic”:“zigbee/xiaomi/set”,“gettopic”:“zigbee/xiaomi/get”,“device”:“0x00158d0003fae69e”,“attribute”:"",“payload”:“plain”,“x”:100,“y”:340,“wires”:[[“112e27b0.d2f7a8”,“3e61ff20.d99a3”]]},{“id”:“112e27b0.d2f7a8”,“type”:“debug”,“z”:“d53ff3b0.4f181”,“name”:"",“active”:true,“tosidebar”:true,“console”:false,“tostatus”:false,“complete”:“false”,“x”:990,“y”:300,“wires”:[]},{“id”:“3e61ff20.d99a3”,“type”:“ui_led”,“z”:“d53ff3b0.4f181”,“group”:“90fa65ca.acc5e8”,“order”:8,“width”:0,“height”:0,“label”:“Büro”,“labelPlacement”:“left”,“labelAlignment”:“left”,“colorForValue”:[{“color”:“red”,“value”:“false”,“valueType”:“bool”},{“color”:“green”,“value”:“true”,“valueType”:“bool”}],“allowColorForValueInMessage”:false,“name”:“Büro”,“x”:970,“y”:340,“wires”:[]},{“id”:“18aac925.9aa317”,“type”:“ui_led”,“z”:“d53ff3b0.4f181”,“group”:“90fa65ca.acc5e8”,“order”:8,“width”:0,“height”:0,“label”:“Fenster Wohnzimmer”,“labelPlacement”:“left”,“labelAlignment”:“left”,“colorForValue”:[{“color”:“red”,“value”:“false”,“valueType”:“bool”},{“color”:“green”,“value”:“true”,“valueType”:“bool”}],“allowColorForValueInMessage”:false,“name”:“Fenster Wohnzimmer”,“x”:1020,“y”:440,“wires”:[]},{“id”:“a310f19e.426d6”,“type”:“debug”,“z”:“d53ff3b0.4f181”,“name”:"",“active”:true,“tosidebar”:true,“console”:false,“tostatus”:false,“complete”:“false”,“x”:990,“y”:400,“wires”:[]},{“id”:“7d62718e.32c71”,“type”:“zigbee-converter”,“z”:“d53ff3b0.4f181”,“shepherd”:“da1e0250.a3327”,“name”:"",“topic”:“zigbee/xiaomi”,“settopic”:“zigbee/xiaomi/set”,“gettopic”:“zigbee/xiaomi/get”,“device”:“0x00158d000431d895”,“attribute”:"",“payload”:“plain”,“x”:100,“y”:440,“wires”:[[“a310f19e.426d6”,“18aac925.9aa317”]]},{“id”:“863a9023.353e6”,“type”:“ui_led”,“z”:“d53ff3b0.4f181”,“group”:“90fa65ca.acc5e8”,“order”:8,“width”:0,“height”:0,“label”:“Fenster Gang”,“labelPlacement”:“left”,“labelAlignment”:“left”,“colorForValue”:[{“color”:“red”,“value”:“false”,“valueType”:“bool”},{“color”:“green”,“value”:“true”,“valueType”:“bool”}],“allowColorForValueInMessage”:false,“name”:“Fenster Gang”,“x”:1000,“y”:540,“wires”:[]},{“id”:“e0ed0a11.971a18”,“type”:“debug”,“z”:“d53ff3b0.4f181”,“name”:"",“active”:true,“tosidebar”:true,“console”:false,“tostatus”:false,“complete”:“false”,“x”:990,“y”:500,“wires”:[]},{“id”:“86176fc1.fb75d”,“type”:“zigbee-converter”,“z”:“d53ff3b0.4f181”,“shepherd”:“da1e0250.a3327”,“name”:"",“topic”:“zigbee/xiaomi”,“settopic”:“zigbee/xiaomi/set”,“gettopic”:“zigbee/xiaomi/get”,“device”:“0x00158d000431f085”,“attribute”:"",“payload”:“plain”,“x”:100,“y”:540,“wires”:[[“e0ed0a11.971a18”,“863a9023.353e6”]]},{“id”:“534ae568.a24e2c”,“type”:“ui_led”,“z”:“d53ff3b0.4f181”,“group”:“90fa65ca.acc5e8”,“order”:8,“width”:0,“height”:0,“label”:“Fenster Schlafzimmer”,“labelPlacement”:“left”,“labelAlignment”:“left”,“colorForValue”:[{“color”:“red”,“value”:“false”,“valueType”:“bool”},{“color”:“green”,“value”:“true”,“valueType”:“bool”}],“allowColorForValueInMessage”:false,“name”:“Fenster Schlafzimmer”,“x”:1020,“y”:640,“wires”:[]},{“id”:“9fccb1eb.a116d”,“type”:“debug”,“z”:“d53ff3b0.4f181”,“name”:"",“active”:true,“tosidebar”:true,“console”:false,“tostatus”:false,“complete”:“false”,“x”:990,“y”:600,“wires”:[]},{“id”:“afee38d.e6a3dc8”,“type”:“zigbee-converter”,“z”:“d53ff3b0.4f181”,“shepherd”:“da1e0250.a3327”,“name”:"",“topic”:“zigbee/xiaomi”,“settopic”:“zigbee/xiaomi/set”,“gettopic”:“zigbee/xiaomi/get”,“device”:“0x00158d0003cd9893”,“attribute”:"",“payload”:“plain”,“x”:100,“y”:640,“wires”:[[“9fccb1eb.a116d”,“534ae568.a24e2c”]]},{“id”:“39c9b2e.596b04e”,“type”:“ui_led”,“z”:“d53ff3b0.4f181”,“group”:“90fa65ca.acc5e8”,“order”:8,“width”:0,“height”:0,“label”:“Türe Balkon”,“labelPlacement”:“left”,“labelAlignment”:“left”,“colorForValue”:[{“color”:“red”,“value”:“false”,“valueType”:“bool”},{“color”:“green”,“value”:“true”,“valueType”:“bool”}],“allowColorForValueInMessage”:false,“name”:“Türe Balkon”,“x”:990,“y”:740,“wires”:[]},{“id”:“e7c4b9dd.65c6d8”,“type”:“debug”,“z”:“d53ff3b0.4f181”,“name”:"",“active”:true,“tosidebar”:true,“console”:false,“tostatus”:false,“complete”:“false”,“x”:990,“y”:700,“wires”:[]},{“id”:“bc61b8b0.b76ee8”,“type”:“zigbee-converter”,“z”:“d53ff3b0.4f181”,“shepherd”:“da1e0250.a3327”,“name”:"",“topic”:“zigbee/xiaomi”,“settopic”:“zigbee/xiaomi/set”,“gettopic”:“zigbee/xiaomi/get”,“device”:“0x00158d0003a012e8”,“attribute”:"",“payload”:“plain”,“x”:100,“y”:740,“wires”:[[“e7c4b9dd.65c6d8”,“39c9b2e.596b04e”]]},{“id”:“da1e0250.a3327”,“type”:“zigbee-shepherd”,“z”:"",“name”:“zigbee2mqtt”,“path”:"/dev/serial/by-id/usb-Texas_Instruments_TI_CC2531_USB_CDC___0X00124B0018E2EE6F-if00",“baudRate”:“115200”,“rtscts”:true,“channelList”:[11],“led”:“enabled”},{“id”:“90fa65ca.acc5e8”,“type”:“ui_group”,“z”:"",“name”:“Fenster und Türkontakte”,“tab”:“bf85fe90.4436c”,“order”:1,“disp”:true,“width”:“6”,“collapse”:false},{“id”:“bf85fe90.4436c”,“type”:“ui_tab”,“z”:"",“name”:“Sicherheit”,“icon”:“dashboard”,“order”:3,“disabled”:false,“hidden”:false}]

Now I am helpless how to use Z2M without having problems all the time.

Maybe someone can help me?

Error Message

pi@raspberrypi:/opt/zigbee2mqtt $ npm start

> zigbee2mqtt@1.10.0 start /opt/zigbee2mqtt
> node index.js

zigbee2mqtt:info  2020-02-11 10:30:14: Logging to console and directory: '/opt/zigbee2mqtt/data/log/2020-02-11.10-30-14' filename: log.txt
zigbee2mqtt:info  2020-02-11 10:30:15: Starting zigbee2mqtt version 1.10.0 (commit #8df6be8)
zigbee2mqtt:info  2020-02-11 10:30:15: Starting zigbee-herdsman...
zigbee2mqtt:info  2020-02-11 10:30:17: zigbee-herdsman started
zigbee2mqtt:info  2020-02-11 10:30:17: Coordinator firmware version: '{"type":"zStack12","meta":{"transportrev":2,"product":0,"majorrel":2,"minorrel":6,"maintrel":3,"revision":20190608}}'
zigbee2mqtt:info  2020-02-11 10:30:17: Currently 0 devices are joined:
zigbee2mqtt:warn  2020-02-11 10:30:17: `permit_join` set to  `true` in configuration.yaml.
zigbee2mqtt:warn  2020-02-11 10:30:17: Allowing new devices to join.
zigbee2mqtt:warn  2020-02-11 10:30:17: Set `permit_join` to `false` once you joined all devices.
zigbee2mqtt:info  2020-02-11 10:30:17: Zigbee: allowing new devices to join.
zigbee2mqtt:info  2020-02-11 10:30:17: Connecting to MQTT server at mqtt//localhost
(node:2816) UnhandledPromiseRejectionWarning: Error: Missing protocol
    at Object.connect (/opt/zigbee2mqtt/node_modules/mqtt/lib/connect/index.js:67:13)
    at /opt/zigbee2mqtt/lib/mqtt.js:66:32
    at new Promise (<anonymous>)
    at MQTT.connect (/opt/zigbee2mqtt/lib/mqtt.js:65:16)
    at Controller.start (/opt/zigbee2mqtt/lib/controller.js:133:25)
(node:2816) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 2)
(node:2816) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.
/opt/zigbee2mqtt/lib/mqtt.js:60
            if (this.client.reconnecting) {
                            ^

TypeError: Cannot read property 'reconnecting' of undefined
    at Timeout._onTimeout (/opt/zigbee2mqtt/lib/mqtt.js:60:29)
    at listOnTimeout (internal/timers.js:531:17)
    at processTimers (internal/timers.js:475:7)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! zigbee2mqtt@1.10.0 start: `node index.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the zigbee2mqtt@1.10.0 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/pi/.npm/_logs/2020-02-11T09_30_27_284Z-debug.log
pi@raspberrypi:/opt/zigbee2mqtt $ ^C
pi@raspberrypi:/opt/zigbee2mqtt $ 

Many thanks in advance

Your configuration is wrong :

mqtt://localhost

Thanks for your help, I have installed the Broker in this variant on my own Raspberry, so it should work with Localhost? or am I wrong?

Thanks for your feedback

Your log shows mqtt//localhost, it should be mqtt://localhost