Some devices do not report linkquality

I’m having small trouble getting all devices to work properly here, I mostly have xiaomi aqara sensors and ikea tradfri lights on my zigbee network. Most devices work just fine, but a few ikea lights do not report linkquality.
The lights who do not report lqi are exactly the same (same model, same firmware) as other lights who do report lqi. I cannot think of any reason why this should not be working for just a few of the lights, where other lights just report lqi fine. In picture below the green marked ones are working just fine, the red ones are not reporting lqi.

Does anyone have a clue what could be wrong and what I can do to fix/debug this ? I tried doing a reconfigure of these lights but that doesn’t work, any other things to try ?

Also I just tried to re-pair the lights which do not report lqi, but this has no result, still the lqi field shows as n/a.
Any help or tips how to debug/fix this would be appreciated.

Is there any chance you’re using a conbee ii stick?

For my coordinator I use the slaesh’s CC2652RB stick, which works fine. Also the other lamps which do report lqi have been paired with the exact same stick.The lamps themselves are working ok, I can normally turn them on/off and dim them via home-assitant via zigbee2mqtt, so that’s not the issue. Only thing is that from the total of ~25 ikea lamps I have here, these 4 do not report lqi, I have no clue as why that is and what I can do to make them report lqi.
Any more suggestions are welcome.