CC2531 as router and CC2530+CC2591 as coordinator?

Hello to all,
I’ve actually a setup with a raspberry as coordinator with CC2531 stick and a CC2530+CC2591 as router.
Due the router is not working correctly and I cannot debug it much, would it possible to invert the hardware? I’ve another raspberry to use, so I could setup the CC2530+CC2591 as coordinator and the CC2531 as router and having logs for everything.
Would that be possible?
Any suggestions instead?
Thanks!
Simon

Sorry, no suggestions? :frowning:

I have a CC2530 coordinator ( attached to an esp01) and 2 CC2531 routers, so this is a viable solution.

Hello @francisp!
Thanks for the answer. so questions:
Is there a guide to attach the CC2530 to ESP01? Possible to a ESP8266 as well?
Which firmware do you use?
And, after flashing the CC2531 as router, do I need to connect it to something (RPi or whatever) or its enough to plug it into any usb power adapter?
Thanks!
Simon

CC2530 -> ESP01 : use this guise :
How to connect a CC2530 coordinator via an ESP8266 | zigbee2mqtt.io

Regular CC2530 coordinator firmware

CC2531 as router can be just plugged in an usb-adapter.

Thanks @francisp
I’ve made some good improovments:
– installed zigbee2mqtt into my NAS via docker
– moved CC2530+CC2591 as coordinator attached to a ESP8266 I’ve found aroud the home with ESPEasy (https://www.zigbee2mqtt.io/information/connecting_cc2530.html#via-an-esp8266)
– re-joined some devices transporting the configuration from my BananaPi board Zigbee to my docker version.
All seems stable right now, the coordinator works better in that way, btw I’ll test it for some days and then let see if it works as expected. Then I’ll move theCC2531 to be a router.
Thanks for the informations provided!!!

Cheers, Simon

Hello @francisp again.
I’ve another question:
Having the CC2530 connected to the ESP8266 and exposed to zigbee via tcp, do I need to setup the option rtscts: false in the advanced settings anyway?
Thanks!
Simon

Yes. At least it does not work in my configuration without.

Hi,

I am implementing the same setup, CC2530+CC2591 connected to a NodeMCU/ESP8266 board.

Can you please advise how to make this setting (rtscts: false) in ESP Easy? I cannot find it among the Serial Server configuration options (please ignore the text marked with a red square, the screenshot is taken from another context):

Thanks,
Cristian

This is my config :

rtscts : false is set in zigbee2mqtt configuration.yaml

Thanks a lot @francisp!

Can you please confirm if these are the good pin connections between the CC2530+CC2591 and the ESP8266?
Are pins P04, P05 and P20 still required to be connected to GND?

Thanks

Yes, that seems ok. I did connect P04, P05 and P20 to GND

OK, got the CC2530+CC2591 and ESP8266 devices hooked up.

Now I am following this guide (install ser2net, configure ser2net, configure Zigbee2mqtt port: option).

In the line:

20108:raw:0:/dev/ttyACM0:115200 8DATABITS NONE 1STOPBIT

Should I replace /dev/ttyACM0 with tcp://<esp_easy_ip>:<esp_easy_serial_server_port> ?

Pardon my silliness… I think in that line I should put the /dev/ttyX virtual serial device which is created by ser2net.
How can I recognize it?

I have the following “non-standard” /dev/tty* devices:

crw-rw---- 1 root dialout 204, 64 Feb 27 01:55 /dev/ttyAMA0
crw------- 1 root root      5,  3 Feb 27 01:52 /dev/ttyprintk
crw-rw---- 1 root dialout   4, 64 Feb 27 01:52 /dev/ttyS0

Thanks


Later edit:

Works flawlessly, thanks a lot!
Just a small remark: the format of the serial port option in configuration.yaml must be this one:

serial:
  port: 'tcp://10.0.0.187:1775'

Cheers,
Cristian

No need to install ser2net, that part is done by espeasy. This should be enough (replace ip, port with your own)

serial:
  port: tcp:10.0.0.187:1775
advanced:
  rtscts: false

I confirm you all. It works well as descrived by @francisp . I’ve followed the official guide: https://www.zigbee2mqtt.io/information/connecting_cc2530.html#via-an-esp8266
Bye, Simon