WXKG02LM (Aqara Double Rocker) will not pair ;(

Hello together,

no matter what i try, the wallswitch will not pair…it is the only aqara/xiaomi device of 30 devices which will not work…

Does anybody has any pointers or ideas for me?

I’m using the exact same switch (WXKG02LM) and it works for me.

	"ieeeAddr": "0x.....",
	"type": "EndDevice",
	"networkAddress": ....,
	"model": "WXKG02LM",
	"vendor": "Xiaomi",
	"description": "Aqara double key wireless wall switch",
	"friendly_name": "garden_switch",
	"manufacturerID": 4151,
	"manufacturerName": "LUMI",
	"powerSource": "Battery",
	"modelID": "lumi.sensor_86sw2",
	"lastSeen": 1586078537363

How did you pair it?

I am holding down the button for 10 seconds until both leds are blinking three times.

What i should mention too: I unbind it from the xiaomi base to transfer it to zigbee2mqtt. because that doesnt work i try to bind it back to the xiaomi base, but even that is not working anymore.

There seems to be different versions, because xiaomi software says i should hold down the button only 5s (not 10s as i need to).

To exclude other errors with the coordinator or something i tried to bind other (xiaomi)devices -> no problem.

  • try to pair nearer to the coordinator
  • replace the battery

I tried both. New battery and pair it 50cm from coordinator. :confused:

It seems your device has a hardware issue.
I’d buy a new one.

i don’t think it’s hardware issue, i’ve the same exact problem, but i’ve got 3 switches, none of them pairs. I’ve paired like 20 other devices (xiaomi, hue, osram…) without any problem, but this WXKG02LM won’t get paired.

Maybe there are several editions but as I posted above I was able to pair mine (approx. 2 years old).

i had mine paired, using for a year aprox until 2 days ago, i did reset to one of them to pair It with zigbee2mqtt and after that It wasnt able to pair with Xiaomi Home app and z2m, the same happened to the other 3 switches.

My knowledge about zigbee don’t let me go further.

Did you remove it (remove device) from the gateway in the Xiaomi Home app?

… and did you press button 1 or 2?

yes i removed it. i did the reset with left button.

but after that i tried reset with right button, and with both, but same result, just nothing.

i’ve got it, i’ve got my devices paired!


Hero of the day!

Today i tried a new device i have ordered…no problems. So i wanted to report it here… now with the trick from dthgti they are both working…

Thank you!

It is as he mentioned it, you have to be patient if you remove the battery…