Is Konke limited channels an issue if using zigbee2mqtt

Hi. First many thanks to Koenkk for creating and sharing this software. I’ve successfully flash both coordinator and router firmware and installed zigbee2mqtt under Docker with Domoticz.

I’m now looking for devices starting with motion sensors. It seems to me starting with HA at this point in time I should go for zigbee 3.0 devices though it’s hard work finding such devices to purchase - the Zigbee Alliance site only lists 7, most cannot be found on shopping sites (maybe not yet to market) and most online shops lack model nos and zigbee version.

I note that Konke make a 3.0 motion sensor but I have a couple of questions:

  1. Is Konke limited channels an issue if using zigbee2mqtt?

  2. Is the model 2AJZ4KPBS on the Supported Devices page the same as this one on the banggood site

I need 4, so affordability and longevity is important (I know that could be a contradiction :wink:

Thanks for reading

I got mine from Banggood, it seems to be genuine, or an exact clone.
It works well.
Yes, Konke is for some reason is limited to channels 15, 20 and 25.
If you swap Z2M channel, you’ll have to re-pair everything.

Thanks for replying. I ordered a SONOFF SNZB motion sensor from itead but have yet to try them. I’m not optimistic as these are Zigbee 3.0 and I forgot that my zigbee2mqtt is using zigbee 1.2. I did try a Xiaomi Mijia Smart Light Sensor Zigbee 3.0 but could not get that to work. Probably should have gone for the older zigbee 1.2 model. Same may apply to the Konke zigbee 3.0 devices.
Was your zigbee 3.0 and were you using zigbee2mqtt 1.2 or 3.0? (I read 3.0 is experimental and may be too demanding on CC2530 devices)


My Konke sensor is indeed 3.0, and my CC2530 coordinator is the stable 1.2 firmware. They communicate without any problems.
In which way did your Xiaomi Light Sensor not work?

Hi Hamish. First of all the luminance sensor was sending out messages every 5 seconds or less. Koenkk asked me to edit the herdsman converters but this did not cure it. Tried removing battery and repairing it and also incrementing the x in {configureKey: x}. Besides reporting frequently the light levels were always at 5 even if covered. After many restarts and resetting it stopped working. May it is broken. Someone else then reported also theirs failed to work after moving to 1.14.1 but I was an earlier version.

Just tried again under 1.14.1 with new batteries. Zigbee2MqttAssistant says unresponsive.